Friday, November 20, 2009

Deploying Apache Axis2-1.5.1-war in jboss-5.1.0.GA

1. First Download the required distributions.
2. Extract the to a location on your hard drive. It is better not to put it in Programme Files in C drive.

3. Deploy Axis2 on JBoss.

Extract the axis2.war file in to /server/default/deploy directory in jboss server. By default it will be extracted to a directory named “axis2” and you need to rename it to “axis2.war”. Then delete xml-apis-1.3.04.jar and xercesImpl-2.8.1.jar from Axis2.war folder/WEB-INF/lib.

4. Deploy Rampart (You downloaded it in section 1).

Copy the jar libraries (there were six jars in my case) in lib directory of Rampart binary distribution to WEB-INF/lib directory of axis2.war and copy the bouncycastle library to WEB-INF/lib directory.
Copy the rampart-1.4.mar and rahas-1.4.mar in module directory of Rampart binary distribution to WEB-INF/modules directory of axis2.war.
(All these modifications happen after you deployed your axis.war folder in jboss)

That's all you have to do...

~Now simply stop any other servers if they are running. Run jboss server by clicking the run.bat in bin folder of jboss.
~Type http://localhost:8080/axis on your browser (In this case it is http://localhost:8080/axis2 coz mine i did not change the original name).

~...Boomed...You will be displayed the Axis home page and several links. Get the experience with axis (I my self tried this and it worked fine for me). So why not You.

Good Luck!!!


Hugo said...

Great Help!! I had a lot of problems with this instalation. Thanks a lot.

nalu said...


thanks for nice guide on axis2 deployment in jboss 5.1.0. It helped me to deploy axis2 successfully. But whne Im trying to access "http://localhost:8080/axis2" then a page appears with massage "the requested resource /axis2/ is not abvailable."

Also important point to note that during axis2 deployment with jboss, a warning appears at the end saying "WARNING [javax.enterprise.resource.webcontainer.jsf.config] (main) Unable to process deployment descriptor for context '/axis2'".

It would be nice if you can give some suggesion to resolve it.